En esta lección aprenderemos como utilizar la función Y y la función O además de conocer como combinarla con la función SI

Esta función recibe como argumentos una serie de expresiones lógicas. Si todas ellas son verdaderas, entonces la fun­ción Y devolverá el valor VERDADERO. Si alguna de las expresiones lógicas es falsa, entonces la función Y en Excel devolverá el valor FALSO.

La sintaxis de la función es:

=Y(valor_lógico1,[valor_lógico2], …

Donde el valor_lógico es una condición que deseas probar y se puede evaluar como VERDADERO o FALSO.

Función Y ejemplo de uso

En el siguiente ejemplo tenemos una lista de alumnos con sus res­pectivas calificaciones en 3 cursos, el instituto al cual asis­ten ha determinado que aquellos alumnos que obtengan un promedio mayor a 8.5 en cada curso, serán acreedores a una beca de un 20% de descuento si en algún curso no obtiene el promedio requerido no podrán obtener la beca

Para dar solución al ejemplo anterior localicemos primera­mente los valores lógicos, los cursos están en la columna C, D y E, por lo que tenemos que

C2>=8.5 D2>=8.5 E2>=8.5

Aplicado a la función tendríamos algo como esto:

=Y(C2>=8.5,D2>=8.5,E2>=8.5)

Función Y en Excel
Función Y en Excel

Función O

La función O tiene una forma similar a la función Y la diferencia es que devolverá un valor verdadero con solo cumplir con uno de los argumentos o condiciones

La sintaxis es similar, basados en el mismo ejemplo tendríamos una función como esta:

=O(C2>=8.5,D2>=8.5,E2>=8.5)

Cuando usar la Función Y y la función O

Un uso común de las funciones Y – O es expandir la utilidad de otras funciones que realizan pruebas lógicas.

Por ejemplo, la función SI realiza una prueba lógica y, luego, devuelve un valor si la prueba se evalúa como VER­DADERO y otro valor si la prueba se evalúa como FALSO. Con la función Y como argu­mento prueba_lógica de la función SI, se pue­den probar varias condiciones diferentes en lugar de sólo una.

Para comprobar esto en la tabla que estamos viendo, queremos que salga una leyenda que diga “Apto para beca” si las calificaciones de cada curso son iguales o superiores a 8.5 y que salga una leyenda que diga “No apto para beca” en caso de no cumplirse el promedio requerido en cada condición.

Entonces tendríamos la siguiente función:

=SI(Y(C2>=8.5,D2>=8.5,E2>=8.5),»APTO PARA BECA»,»NO APTO PARA BECA»)

Función Y en Excel junto con Función SI

Si tienes alguna duda, puedes dejar tu comentario

Deja un comentario

Cerrar menú