En esta lección aprenderemos a utilizar la función INDICE en Excel. Esta función nos permite mostrar el valor de una matriz de datos al indicarle la posición de la fila y columna donde se encuentra el dato que necesitamos.

La sintaxis para este función es:

=INDICE(matriz,número de fila,número de columna)

Donde:

Matriz: es el rango de celdas en el cual se buscará

Número de fila: el numero de la fila dentro de la matriz

Número de columna: el número de columna dentro de la matriz

Función INDICE – ejemplo básico

Tenemos la siguiente tabla de frutas

Un formulario en el cual colocaremos el numero de fila y columna a modo que funcionarán como coordenada para mostrar el valor encontrado en la celda F3

Lo que haremos es colocar la función INDICE EN la celda F3 usando como referencias las celdas F1 para fila y F2 para columna, entonces tendremos

=INDICE(A2:B9,F1,F2)

Función INDICE EJEMPLO 1

De esta forma al escribir un numero de fila en la celda F1 y un numero de columna en la celda F2 obtendremos el valor buscado en esas coordenadas dentro del rango matriz

Función INDICE – ejemplo básico 2

Si optamos por buscar en rangos separados, podemos establecer en que sección se buscará la coordenada de fila y columna, basándonos en el ejemplo anterior, las categorías de frutas y verduras se encuentran separadas por una columna, lo conveniente sería no tomar en cuenta la columna vacía.

Entonces lo que haremos es agregar un nuevo valor a nuestra sintaxis para determinar en qué área se buscará la fila y columna

De esta forma nuestra función quedará de la siguiente manera

=INDICE((A2:A9,C2:C9),G1,G2,G3)

Función INDICE EJEMPLO 2

De esta forma las referencias para buscar son 2 rangos, el numero de fila lo escribimos en G1, el numero de columna en G2 y el área (rango) en el que se buscará lo escribimos en G3

Función INDICE + COINCIDIR

Mediante un ejemplo sencillo, combinemos las funciones INDICE y COINCIDIR para encontrar un valor.

Primero, tenemos una tabla de artículos cualquiera como esta:

Segundo, tenemos un formulario donde capturaremos una clave de articulo en la celda H2 y de forma automática se mostrará el resultado en las celdas H3 y H4

Antes de escribir la función te recomiendo escribir una clave de algún producto en la celda H2, para este ejemplo voy a escribir la clave A4

Para buscar el nombre del producto, en la celda H3 escribiremos las funciones combinadas de la siguiente manera:

=INDICE(A2:C9,COINCIDIR(H2,A2:A9,0),2)

Función INDICE + COINCIDIR

Explicación:

En esta función primero colocamos la matriz en la que se buscarán los datos.

Según la sintaxis de INDICE deberíamos escribir el numero de fila que corresponde a la clave, en este ejemplo es obvio donde se encuentra, pero es un ejemplo a escala, entonces debemos considerar que la tabla podría estar en otra hoja o bien podrían ser muchos registros, además considera que la clave podrá variar.

Entonces la fila dentro de la función debería ser dinámica en relación con la clave. Para hacer esto nos apoyamos de la función COINCIDIR que se encargará de devolver el numero de fila en la cual se encuentra la clave buscada

Y para finalizar según la sintaxis de la función INDICE, solo nos queda indicar en que columna se encuentra el valor que queremos mostrar, en este caso el nombre del producto esta en la columna numero 2 dentro de la matriz

Función INDICE + COINCIDIR o BUSCARV

Seguro en este punto estás pensando, vaya creo que eso hubiera sido más fácil si utilizáramos la función BUSCARV.

Y desde un punto de vista tienes razón, pero que pasaría si cambiáramos el formulario conservando el orden de la tabla

Ahora buscaremos la información en base al producto y no en base a la clave. Entonces BUSCARV tal como la conocemos no podría funcionar ya que busca el valor buscado más a la izquierda dentro de la matriz y podemos ver que en la matriz el valor a la izquierda es clave y no el nombre del producto y recuerda que no debemos alterar la tabla.

Entonces si jugamos un poco y reacomodamos los valores dentro de la función anterior tenemos algo como esto:

=INDICE(A2:C9,COINCIDIR(H2,B2:B9,0),1)

Simplemente cambiamos el rango en la función coincidir ya que ahora estamos buscando en base al nombre del producto, lógicamente también debemos cambiar el número de columna de acuerdo con los valores que buscamos la clave esta en la columna 1 dentro de la matriz mientras que precio esta en la columna 3 dentro de la matriz

Función INDICE ejemplo terminado

Función INDICE + COINCIDIR Ejemplo con tabla en acomodo horizontal

Esta combinación de funciones se presta para jugar con los valores, en este ejemplo se han acomodado los productos en un formato horizontal, que no es muy común, pero podría presentarse el caso.

Y tenemos un formulario donde debemos mostrar los datos de acuerdo con el producto que se capture en la celda B9

Entonces tenemos como resultado la siguiente función

=INDICE(A1:H3,2,COINCIDIR(B9,A1:H1,0),1)

Función INDICE HORIZONTAL

Si observas la función, solo hemos cambiado de ubicación la función coincidir, ya que ahora son los productos los que se encuentran en columnas variables

Función INDICE

Te he mostrado estos ejemplos trabajando en una sola hoja para que puedas observar a detalle, sin embargo, considera que puedes trabajar colocando las tablas que funcionen como matriz en una hoja y el formulario de búsqueda en otra.

En caso de trabajar con 2 o mas hojas te sugiero utilizar referencias absolutas sobre todo si vas a buscar varios valores y estás pensando utilizar autorrelleno para no escribir función por función

Deja una respuesta

Cerrar menú